Mysidia Adoptables Support Forum  

Home Community Mys-Script Creative Off-Topic
Go Back   Mysidia Adoptables Support Forum > Mysidia Adoptables > Questions and Supports

Reply
 
Thread Tools Display Modes
  #21  
Old 11-03-2017, 04:50 PM
Dinocanid's Avatar
Dinocanid Dinocanid is offline
Member
 
Join Date: Aug 2016
Location: Maryland, USA
Posts: 494
Gender: Unknown/Other
Credits: 18,720
Dinocanid is on a distinguished road
Default

Sure xD
Here are a few screenshots I just took:


(this last one is actually an older screenshot I took)

I'm still working on developing new markings since I only have about 20 or so at the moment, which causes a lot of wolves to look the same/similar.
__________________
Reply With Quote
  #22  
Old 11-03-2017, 05:04 PM
gwynmil's Avatar
gwynmil gwynmil is offline
Member
 
Join Date: Sep 2017
Location: UK
Posts: 24
Gender: Female
Credits: 968
gwynmil is on a distinguished road
Default

Ooooh! Very inspiring, yes. :D Though I see what you mean. Looks like 1, 2 and 5 have the same marking.
If you have a public development thread, blog or anything then I'd be interested to follow and see how it goes.

Well, it's late now. Will try wrangling with the image script tomorrow.
Reply With Quote
  #23  
Old 11-03-2017, 05:07 PM
Dinocanid's Avatar
Dinocanid Dinocanid is offline
Member
 
Join Date: Aug 2016
Location: Maryland, USA
Posts: 494
Gender: Unknown/Other
Credits: 18,720
Dinocanid is on a distinguished road
Default

I have a dev thread for it here: link
I post the most frequent updates on TGL though: link
__________________
Reply With Quote
  #24  
Old 11-04-2017, 02:56 PM
gwynmil's Avatar
gwynmil gwynmil is offline
Member
 
Join Date: Sep 2017
Location: UK
Posts: 24
Gender: Female
Credits: 968
gwynmil is on a distinguished road
Default

Will check them out!

But firstly, uh... I seem to have destroyed everything?? Following Kyttias' notes on editing the indexview page, I logged out to see if Guest would appear instead of username, and suddenly every page is blank. >_<

Parse error: syntax error, unexpected 'public' (T_PUBLIC) in /home/griffusi/public_html/view/indexview.php on line 3

If the "public" is removed,

Fatal error: Class 'IndexView' not found in /home/griffusi/public_html/classes/class_controller.php on line 135

(I'm an idiot, ignore the above)

I saved the default code, and pasted it back in, but it now gives this instead:

Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template file 'template.tpl'' in /home/griffusi/public_html/inc/smarty/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /home/griffusi/public_html/inc/smarty/sysplugins/smarty_internal_templatebase.php(374): Smarty_Internal_TemplateBase->fetch('template.tpl', NULL, NULL, NULL, true) #1 /home/griffusi/public_html/classes/class_template.php(135): Smarty_Internal_TemplateBase->display('template.tpl') #2 /home/griffusi/public_html/classes/class_view.php(280): Template->output() #3 /home/griffusi/public_html/classes/class_frontcontroller.php(102): View->render() #4 /home/griffusi/public_html/index.php(74): FrontController->render() #5 /home/griffusi/public_html/index.php(78): IndexController::main() #6 {main} thrown in /home/griffusi/public_html/inc/smarty/sysplugins/smarty_internal_templatebase.php on line 127

Seems there's nothing I can do. Ahhh. (flailing helplessly)

edit: line 127.
throw new SmartyException("Unable to load template {$_template->source->type} '{$_template->source->name}'{$parent_resource}");

No idea what to make of that. I had used the Mysidia admincp editor to add a few lines of text earlier, before deciding to try this instead. Has it caused a conflict by "overwriting" the old stuff, or something?

Last edited by gwynmil; 11-04-2017 at 03:58 PM.
Reply With Quote
  #25  
Old 11-04-2017, 03:28 PM
Hall of Famer's Avatar
Hall of Famer Hall of Famer is online now
Administrator, Lead Coder
 
Join Date: Dec 2008
Location: Somerville
Posts: 4,388
Gender: Male
Credits: 122,197
Hall of Famer is on a distinguished road
Default

Looks like some kind of syntax error, can you show the code in the entire file? Either post it here or show it in pastebin.
__________________


Mysidia Adoptables, a free and ever-improving script for aspiring adoptables/pets site.
Reply With Quote
  #26  
Old 11-04-2017, 03:36 PM
gwynmil's Avatar
gwynmil gwynmil is offline
Member
 
Join Date: Sep 2017
Location: UK
Posts: 24
Gender: Female
Credits: 968
gwynmil is on a distinguished road
Default

Sure, this was the modified indexview.php

PHP Code:
class IndexView extends View{

    public function 
index(){
        
$mysidia Registry::get("mysidia");
        
$document $this->document;        
        
$document->setTitle(" Your Title Here ");
        
        
$name = (!$mysidia->user->isloggedin)?"Guest":$mysidia->user->username;
        
$document->add(new Comment(" Welcome, {$name}! <br>"FALSE));

        
$document->add(new Comment("<h2>In development</h2><br><br>This will be a griffin breeding game. Emphasis on <b>will be</b>... we still have a very long way to go.<br>
            <div style='width:600px;height;200px;padding:20px;background-color:white;text-align:center;margin-top:30px;'>
                Here is a div. Later to feature some griffins.</div>"
));
    
    } 

And back to the default:

PHP Code:
class IndexView extends View{
    
    public function 
index(){
        
$frame Registry::get("frame");
        
$frame->getDocument("index");
    }

The other files (classes, smarty) have not been touched at all since the Mysidia installation.

(edit: ignore the syntax error earlier, that was from when I was an absolute idiot and forgot to include the first class IndexView extends View{ part. Good lord. Still got the template error, no matter what.)

---

Edit again: looked through all the errors, it's always about template.tpl. My two themes are totally unchanged though...

Just realised this was the first time I'd logged out, for several days. I changed the Green theme to act as the new site layout, and deleted the Main and Elements ones. Can't remember if something was done, to set it to the new default... but someone did say it was safe to delete the other two.

Could this be the real issue? If so, how do I reinstate the Main theme for guests not-logged-in? The files are still here in cpanel.

(Hmm, I will email my co-designer, ask if she's still logged in and can view pages normally. If yes, hopefully she can upload the theme again using the admincp.)

Yet another edit: added the two themes back in the DB table, with id 1 and 2. adopts_settings still says Green is the default; it can't be changed in this table. Will keep looking... pretty much any change should be possible via cpanel, right?


Final edit: nope, can't find any way. Not hearing anything back from co-designer either. Maybe tomorrow...
If it's relevant, the admincp pages still look fine, I just can't log in anywhere. Wonder if it would be possible to set up a temporary login form/page under that area?

Who knew that editing the index page and/or logging out could cause so much trouble? x) Wish I hadn't done that. I'd been hoping to spend all evening working on a bunch of features.

Last edited by gwynmil; 11-04-2017 at 08:04 PM.
Reply With Quote
  #27  
Old 11-05-2017, 08:37 AM
gwynmil's Avatar
gwynmil gwynmil is offline
Member
 
Join Date: Sep 2017
Location: UK
Posts: 24
Gender: Female
Credits: 968
gwynmil is on a distinguished road
Default

OK, crisis averted! Co-designer was still logged in and could view things as normal. She added a fresh Main theme back in and the template error is gone.

Only problem is that the login page is restricted to members only (lol, how did that happen?) but that shouldn't be hard to fix.

Dinocanid, your game-in-progress looks good! Nice layout, and the interactive explore thingy is especially cool.

Maybe we could start a development thread for our game too. Not sure how early is too early, but we do have loads of scribbly griffin concept art to post, I guess.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:07 PM.

Currently Active Users: 190 (1 members and 189 guests)
Threads: 3,925, Posts: 31,302, Members: 15,505
Welcome to our newest members, harryray.
BER





What's New?

What's Hot?

What's Popular?


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
vBCommerce I v2.0.0 Gold ©2010, PixelFX Studios
vBCredits I v2.0.0 Gold ©2010, PixelFX Studios
Emoticons by darkmoon3636