Mysidia Adoptables Support Forum  

Home Community Mys-Script Creative Off-Topic
Go Back   Mysidia Adoptables Support Forum > parayna

Conversation Between parayna and Hall of Famer
Showing Visitor Messages 1 to 7 of 7
  1. parayna
    09-08-2015 11:37 AM
    parayna
    OK, thanks. I just backed everything up and sent you the information XD I have been using WAMP so I just transferred everything to the one on the web so yeah XD
  2. Hall of Famer
    09-08-2015 11:19 AM
    Hall of Famer
    I see, I guess in next version I should add a red-colored note above the username field that it is advised to contain only alphanumeric characters. But its okay, I understand. I will see what I can do for you.
  3. parayna
    09-08-2015 11:10 AM
    parayna
    OK ^_^ Thanks for answering! If it's alright, I will PM you the information and everything but it's fine if you can't do it. I think members just seemed to want to sign up with the symbol in their usernames XD
  4. Hall of Famer
    09-08-2015 10:15 AM
    Hall of Famer
    Well at this point the best idea is to only use alphanumeric characters(A-Z, a-z, 0-9) plus empty space or underscore(" " and "_") characters as your username. The other symbol characters have special meanings in PHP and URL, some can be manipulated by hackers to attack your site and database. So I usually filter them from user input(form or URL), the filtered result may lead to loss or modification of the very symbol you use. In fact, Id say Realitys Madness is a good username to me, I usually am too lazy to type the single quote symbol myself.

    But if you really need to use single quote in username, I can find a workaround for you. Send me your FTP login information and I will modify the script on your site and make it work for you, possibly tonight or tomorrow it will be done.
  5. parayna
    09-07-2015 06:02 PM
    parayna
    Hello, I posted this in the bug tracker a while ago and forgot to ask for help after a few weeks XD I have discovered that if someone signs up with an apostrophe in their username, it adds a slash into the Member's list and throws an error when trying to access their page.

    It pops up with this:

    Invalid ID Specified

    Sorry, but we could not find a user in the system with the username you have specified. Please make sure you have the username right. The user's account may also have been deleted by the system admin...

    With this in the URL box: /profile/view/Realilty\

    The user's name is Realilty's Madness but the slash it pops up with messes it up :/

    Do you know how to fix it? This is the full link if you need it: http://ycadopts.byethost4.com/profile/view/Realilty\

    The slash also appears on the members list page. Thanks for any help ^_^
  6. parayna
    10-30-2013 07:56 AM
    parayna
    Yes, thank you! I fixed the A by editing the template files, like you posted up. ^-^
  7. Hall of Famer
    10-30-2013 07:22 AM
    Hall of Famer
    Hi there did u check the bug fix for weird character A in bug tracker? Did it fix ur shoutbox?

All times are GMT -5. The time now is 03:33 AM.

Currently Active Users: 83 (2 members and 81 guests)
Threads: 3,998, Posts: 31,601, Members: 15,650
Welcome to our newest members, dessly.
BETA





What's New?

What's Hot?

What's Popular?


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
vBCommerce I v2.0.0 Gold ©2010, PixelFX Studios
vBCredits I v2.0.0 Gold ©2010, PixelFX Studios
Emoticons by darkmoon3636